PhotoMagic - System requirements

Windows 7, Vista, XP, 2008, 2003, 2000, NT4, ME, 98, or 95

Mac OS X Snow Leopard (10.6), Leopard (10.5), Tiger (10.4), or Panther (10.3)
(PhotoMagic is not compatible with OS X Lion (10.7))

Note: the PhotoPrint software included is Windows only!


Info Want to stay up-to-date? Enter your email address to receive our occasional newsletter.
Your address will never be shared, and you can easily unsubscribe at all times.

Name:   Email Address:  

Copyright © 2005-2016 BenVista Ltd., All Rights Reserved | About Us | Contact Us | Site Map